Skip to content

← Public intelligence

Packagist package

symfony/phpunit-bridge

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PackagistPublished

    Deserialization of untrusted data in Symfony

    CVE-2019-10912 · GHSA-w2fr-65vp-mxw3

    Affected
    • Packagist symfony/phpunit-bridge >= 2.8.0, < 2.8.50; >= 3.0.0, < 3.4.26; >= 4.0.0, < 4.1.12; >= 4.2.0, < 4.2.7
    Fixed in
    2.8.504.1.124.2.73.4.26· Vendor fix available
    Issue
    In Symfony before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, it is possible to cache objects that may contain bad user input. On serialization or unserialization, this could result in the deletion of files that the current user has access to. This is related to symfony/cache and symfony/phpunit-bridge.

    Recommended action: Upgrade to 4.2.7, 4.1.12, 3.4.26 or 2.8.50 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →