Skip to content

← Public intelligence

Packagist package

symfony/dependency-injection

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    Symfony XML Entity Expansion security vulnerability

    GHSA-c636-cg5r-2498

    Affected
    • Packagist symfony/dependency-injection >= 2.0.0, < 2.0.17
    Fixed in
    2.0.17· Vendor fix available
    Issue
    Symfony 2.0.11 carried a [similar] XXE security fix, however, on review of ZF2 I also noted a vulnerability to XML Entity Expansion (XEE) attacks whereby all extensions making use of libxml2 have no defense against XEE Quadratic Blowup Attacks. The vulnerability is a function of there being no current method of disabling custom entities in PHP (i.e. defined internal to the XML document without using external entities). In a QBA, a long entity can be defined and then referred to multiple times in document elements, creating a memory sink with which Denial Of Service attacks against a host's RAM can be mounted. The use of the LIBXMLNOENT or equivalent option in a dependent extension amplified the impact (it doesn't actually mean "No Entities"). In addition, libxml2's innate defense against the related Exponential or Billion Laugh's XEE attacks is active only so long as the LIBXMLPARSEHUGE is NOT set (it disables libxml2's hardcoded entity recursion limit). No instances of these two…

    Recommended action: Upgrade to 2.0.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Symfony Service IDs Allow Injection

    CVE-2019-10910 · GHSA-pgwj-prpq-jpc2

    Affected
    • Packagist symfony/dependency-injection >= 2.7.0, < 2.7.51; >= 2.8.0, < 2.8.50; >= 3.0.0, < 3.4.26; >= 4.0.0, < 4.1.12; >= 4.2.0, < 4.2.7
    Fixed in
    2.8.504.1.122.7.514.2.73.4.26· Vendor fix available
    Issue
    In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.

    Recommended action: Upgrade to 4.2.7, 4.1.12, 3.4.26 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →