Medium, CVSS 4.8PackagistPublished
XSS injection in the Grid component of Sylius
CVE-2019-12186 · GHSA-rc5r-697f-28x6
- Affected
- Packagist sylius/grid >= 1.0.0, < 1.1.19; >= 1.2.0, < 1.2.18; >= 1.3.0, < 1.3.13; >= 1.4.0, < 1.4.5; >= 1.5.0, < 1.5.1
- Fixed in
- 1.4.51.3.131.2.181.1.191.5.1· Vendor fix available
- Issue
- Grid component of Sylius omits HTML input sanitisation while rendering object implementing toString() method through the string field type.
Recommended action: Upgrade to 1.5.1, 1.4.5, 1.3.13 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.