Skip to content

← Public intelligence

Packagist package

spipu/html2pdf

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    Spipu HTML2PDF vulnerable to cross-site scripting

    CVE-2023-39062 · GHSA-99fg-2h75-m92h

    Affected
    • Packagist spipu/html2pdf < 5.2.8
    Fixed in
    5.2.8· Vendor fix available
    Issue
    Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote attacker to execute arbitrary code via a crafted script to the forms.php.

    Recommended action: Upgrade to 5.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8PackagistPublished

    Cross-site Scripting in HTML2PDF

    CVE-2021-45394 · GHSA-6m93-343m-3jrc

    Affected
    • Packagist spipu/html2pdf < 5.2.4
    Fixed in
    5.2.4· Vendor fix available
    Issue
    An issue was discovered in Spipu HTML2PDF before 5.2.4. Attackers can trigger deserialization of arbitrary data via the injection of a malicious <link tag in the converted HTML document.

    Recommended action: Upgrade to 5.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →