Critical, CVSS 9.8PackagistPublished
silverstripe restfulserver and registry modules SQL injection vulnerability
CVE-2019-12149 · GHSA-4j6v-3895-8g2j
- Affected
- Packagist silverstripe/restfulserver >= 2.1.0, < 2.1.2; >= 1.0.0, < 1.0.9; >= 2.0.0, < 2.0.4
- Fixed in
- 1.0.92.1.22.0.4· Vendor fix available
- Issue
- SQL injection vulnerability in silverstripe/restfulserver module 1.0.x before 1.0.9, 2.0.x before 2.0.4, and 2.1.x before 2.1.2 and silverstripe/registry module 2.1.x before 2.1.1 and 2.2.x before 2.2.1 allows attackers to execute arbitrary SQL commands.
Recommended action: Upgrade to 2.1.2, 2.0.4 or 1.0.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.