Critical, CVSS 9.8PackagistPublished
Insecure Deserialization of untrusted data in rmccue/requests
CVE-2021-29476 · GHSA-52qp-jpq7-6c54
- Affected
- Packagist rmccue/requests >= 1.6.0, < 1.8.0
- Fixed in
- 1.8.0· Vendor fix available
- Issue
- Impact Unserialization of untrusted data. Patches The issue has been patched and users of Requests 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0. References Publications about the vulnerability: https://dannewitz.ninja/posts/php-unserialize-object-injection-yet-another-stars-rating-wordpress https://github.com/ambionics/phpggc/issues/52 https://blog.detectify.com/2019/07/23/improving-wordpress-plugin-security/ https://i.blackhat.com/us-18/Thu-August-9/us-18-Thomas-Its-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-Know-It.pdf https://cdn2.hubspot.net/hubfs/3853213/us-18-Thomas-It%27s-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-....pdf https://2018.zeronights.ru/wp-content/uploads/materials/9%20ZN2018%20WV%20-%20PHP%20unserialize.pdf https://medium.com/@knownsec404team/extend-the-attack-surface-of-php-deserialization-vulnerability-via-phar-d6455c6a1066#3c0f Originally fixed in WordPress 5.5.2:…
Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.