Skip to content

← Public intelligence

Packagist package

ptrofimov/beanstalk_console

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3PackagistPublished

    Cross-site Scripting in Beanstalk console

    CVE-2022-0539 · GHSA-2cjf-w7c4-fhf6

    Affected
    • Packagist ptrofimov/beanstalk_console < 1.7.14
    Fixed in
    1.7.14· Vendor fix available
    Issue
    Beanstalk console (ptrofimov/beanstalkconsole) prior to 1.7.14 is vulnerable to cross-site scripting.

    Recommended action: Upgrade to 1.7.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    Cross-site Scripting in Beanstalk console

    CVE-2022-0501 · GHSA-gj85-pvp5-mvf9

    Affected
    • Packagist ptrofimov/beanstalk_console < 1.7.12
    Fixed in
    1.7.12· Vendor fix available
    Issue
    Beanstalk console prior to version 1.7.12 is vulnerable to cross-site scripting.

    Recommended action: Upgrade to 1.7.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →