Medium, CVSS 5.4PackagistPublished
Cross-site Scripting in pegasus/google-for-jobs
CVE-2021-43561 · GHSA-hfm8-2q22-h7hv
- Affected
- Packagist pegasus/google-for-jobs < 1.5.1; >= 2.0.0, < 2.1.1
- Fixed in
- 1.5.12.1.1· Vendor fix available
- Issue
- An XSS issue was discovered in the googleforjobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Recommended action: Upgrade to 2.1.1 or 1.5.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.