Medium, CVSS 6.1PackagistPublished
PayPal PHP Merchant SDK Cross-site scripting (XSS) vulnerability
CVE-2017-6099 · GHSA-p4g7-wjhq-9r2h
- Affected
- Packagist paypal/merchant-sdk-php >= 3.0.0, < 3.12.0
- Fixed in
- 3.12.0· Vendor fix available
- Issue
- Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.
Recommended action: Upgrade to 3.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.