Medium, CVSS 5.3PackagistPublished
Paymorrow Improper Input Validation vulnerability
CVE-2018-14020 · GHSA-489x-ccjw-q7c4
- Affected
- Packagist oxid-esales/paymorrow-module >= 1.0.0, < 1.0.2; >= 2.0.0, < 2.0.1
- Fixed in
- 2.0.11.0.2· Vendor fix available
- Issue
- An issue was discovered in the Paymorrow module 1.0.0 before 1.0.2 and 2.0.0 before 2.0.1 for OXID eShop. An attacker can bypass delivery-address change detection if the payment module doesn't use eShop's checkout procedure properly. To do so, the attacker must change the delivery address to one that is not verified by the Paymorrow module.
Recommended action: Upgrade to 2.0.1 or 1.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.