High, CVSS 8.7PackagistPublished
Potential Remote Code Execution vulnerability
CVE-2020-15227 · GHSA-8gv3-3j7f-wg94
- Affected
- Packagist nette/application >= 2.2.0, < 2.2.10; >= 2.3.0, < 2.3.14; >= 2.4.0, < 2.4.16; >= 3.0.0, < 3.0.6; >= 2.0.0, < 2.0.19; >= 2.1.0, < 2.1.13
- Fixed in
- 2.3.142.4.163.0.62.2.102.1.132.0.19· Vendor fix available
- Issue
- Packages nette/application versions prior to 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette versions prior to 2.0.19 and 2.1.13 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Reported by Cyku Hong from DEVCORE (https://devco.re) Impact Code injection, possible remote code execution. Patches Fixed in nette/application 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette 2.0.19 and 2.1.13
Recommended action: Upgrade to 3.0.6, 2.4.16, 2.3.14 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.