Skip to content

← Public intelligence

Packagist package

melisplatform/melis-cms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PackagistPublished

    Melis Platform CMS SQL Injection

    CVE-2025-10351 · GHSA-mrmx-jfw8-qhgv

    Affected
    • Packagist melisplatform/melis-cms < 5.3.4
    Fixed in
    5.3.4· Vendor fix available
    Issue
    SQL injection vulnerability based on the melis-cms module of the Melis platform from Melis Technology. This vulnerability allows an attacker to retrieve, create, update, and delete databases through the 'idPage' parameter in the '/melis/MelisCms/PageEdition/getTinyTemplates' endpoint.

    Recommended action: Upgrade to 5.3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.7PackagistPublished

    melisplatform/melis-cms vulnerable to deserialization of untrusted data

    CVE-2022-39297 · GHSA-m3m3-6gww-7gj9

    Affected
    • Packagist melisplatform/melis-cms < 5.0.1
    Fixed in
    5.0.1· Vendor fix available
    Issue
    Impact Attackers can deserialize arbitrary data on affected versions of melisplatform/melis-cms, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to melisplatform/melis-cms = 5.0.1. Patches This issue was addressed by restricting allowed classes when deserializing user-controlled data. References - https://github.com/melisplatform/melis-cms/commit/d124b2474699a679a24ec52620cadceb3d4cec11 For more information If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an email to vulnerability.research [at] sonarsource.com; - The maintainers, by opening an issue on this repository.

    Recommended action: Upgrade to 5.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →