Medium, CVSS 6.1PackagistPublished
Cross-site Scripting in DaSchTour matomo-mediawiki-extension
CVE-2017-20175 · GHSA-hc67-v29c-7g78
- Affected
- Packagist mediawiki/matomo < 2.4.3
- Fixed in
- 2.4.3· Vendor fix available
- Issue
- A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The name of the patch is 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.
Recommended action: Upgrade to 2.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.