Medium, CVSS 5.3PackagistPublished
Improper permissions handling in MediaWiki AbuseFilter
CVE-2024-47913 · GHSA-rmcp-9fhq-58pv
- Affected
- Packagist mediawiki/abuse-filter < 1.39.9; >= 1.40.0, < 1.41.3; >= 1.42.0, < 1.42.2
- Fixed in
- 1.39.91.42.21.41.3· Vendor fix available
- Issue
- An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.
Recommended action: Upgrade to 1.42.2, 1.41.3 or 1.39.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.