Skip to content

← Public intelligence

Packagist package

magento/product-community-edition

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8PackagistPublished

    Magento 2 Community Edition XSS Vulnerability

    CVE-2019-7938 · GHSA-mgfr-44wv-hqv6

    Affected
    • Packagist magento/product-community-edition >= 2.1, < 2.1.18; >= 2.2, < 2.2.9; >= 2.3, < 2.3.2
    Fixed in
    2.1.182.2.92.3.2· Vendor fix available
    Issue
    A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify catalog price rules to inject malicious javascript.

    Recommended action: Upgrade to 2.3.2, 2.2.9 or 2.1.18 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8PackagistPublished

    Magento 2 Community Edition RCE Vulnerability

    CVE-2019-7876 · GHSA-6qh6-v99h-vh4c

    Affected
    • Packagist magento/product-community-edition >= 2.1, < 2.1.18; >= 2.2, < 2.2.9; >= 2.3, < 2.3.2
    Fixed in
    2.1.182.2.92.3.2· Vendor fix available
    Issue
    A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to manipulate layouts can insert a malicious payload into the layout.

    Recommended action: Upgrade to 2.3.2, 2.2.9 or 2.1.18 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8PackagistPublished

    Magento 2 Community Edition CSRF Vulnerability

    CVE-2019-7865 · GHSA-wmrg-w9vg-7jqx

    Affected
    • Packagist magento/product-community-edition >= 2.1, < 2.1.18; >= 2.2, < 2.2.9; >= 2.3, < 2.3.2
    Fixed in
    2.1.182.2.92.3.2· Vendor fix available
    Issue
    A cross-site request forgery (CSRF) vulnerability exists in the checkout cart item of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited at the time of editing or configuration.

    Recommended action: Upgrade to 2.3.2, 2.2.9 or 2.1.18 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. UnratedPackagistPublished

    Using JS libraries with known security vulnerabilities

    CVE-2019-8121 · GHSA-89ch-hqf9-rgp3

    Affected
    • Packagist magento/product-community-edition >= 2.2, < 2.2.10; >= 2.3, < 2.3.2-p2
    Fixed in
    2.3.2-p22.2.10· Vendor fix available
    Issue
    An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Magento 2 codebase leveraged outdated versions of JS libraries (Bootstrap, jquery, Knockout) with known security vulnerabilities.

    Recommended action: Upgrade to 2.3.2-p2 (pre-release) or 2.2.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →