Medium, CVSS 4.8PackagistPublished
Magento 2 Community Edition XSS Vulnerability
CVE-2019-7938 · GHSA-mgfr-44wv-hqv6
- Affected
- Packagist magento/magento1ee >= 1, < 1.14.4.2
- Fixed in
- 1.14.4.2· Vendor fix available
- Issue
- A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify catalog price rules to inject malicious javascript.
Recommended action: Upgrade to 1.14.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.