Skip to content

← Public intelligence

Packagist package

laravel/socialite

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPackagistPublished

    Insecure State Generation in laravel/socialite

    GHSA-h97c-qp24-439v

    Affected
    • Packagist laravel/socialite >= 1.0.0, < 2.0.9
    Fixed in
    2.0.9· Vendor fix available
    Issue
    laravel/socialite versions prior to 2.0.9 are found to have an insecure state generation mechanism, potentially exposing the OAuth authentication process to security risks. The issue has been addressed in version 2.0.9 by ensuring that the state is generated using a truly random approach, enhancing the security of the OAuth flow.

    Recommended action: Upgrade to 2.0.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedPackagistPublished

    State Guessing Vulnerability in laravel/socialite

    GHSA-7fjv-25q9-2w88

    Affected
    • Packagist laravel/socialite >= 1.0.0, < 2.0.10
    Fixed in
    2.0.10· Vendor fix available
    Issue
    laravel/socialite versions prior to 2.0.10 are susceptible to a security vulnerability related to state guessing during OAuth authentication. This vulnerability could potentially lead to session hijacking, allowing attackers to compromise user sessions. The issue has been addressed and fixed in version 2.0.10.

    Recommended action: Upgrade to 2.0.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →