Critical, CVSS 9.8PackagistPublished
CodeIgniter and Kohana vulnerable to PHP Object Injection
CVE-2014-8684 · GHSA-w9ph-q4h9-rwq6
- Affected
- Packagist kohana/core < 3.3.3
- Fixed in
- 3.3.3· Vendor fix available
- Issue
- CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.
Recommended action: Upgrade to 3.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.