Skip to content

← Public intelligence

Packagist package

kevinpapst/kimai2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    Kimai v2 is vulnerable to Cross-Site Scripting (XSS)

    CVE-2019-15481 · GHSA-7v44-75jf-22gj

    Affected
    • Packagist kevinpapst/kimai2 < 1.1
    Fixed in
    1.1· Vendor fix available
    Issue
    Kimai v2 before 1.1 has XSS via a timesheet description.

    Recommended action: Upgrade to 1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.8PackagistPublished

    Improper Neutralization of Formula Elements in a CSV File in Kimai 2

    CVE-2021-43515 · GHSA-64fq-9c6w-rq44

    Affected
    • Packagist kevinpapst/kimai2 < 1.14.1
    Fixed in
    1.14.1· Vendor fix available
    Issue
    A CSV Injection vulnerablity exists in Kimai Kimai 2 prior to 1.14.1 via a description in a new timesheet.

    Recommended action: Upgrade to 1.14.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5PackagistPublished

    Cross-Site Request Forgery in kimai2

    CVE-2021-4033 · GHSA-4jwx-78vx-gm6g

    Affected
    • Packagist kevinpapst/kimai2 < 1.16.7
    Fixed in
    1.16.7· Vendor fix available
    Issue
    CSRF in saving invoices / modifying status of invoices (pending and cancel only)

    Recommended action: Upgrade to 1.16.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.3PackagistPublished

    Cross-site Scripting in kimai2

    CVE-2021-3983 · GHSA-67c7-5v9j-227r

    Affected
    • Packagist kevinpapst/kimai2 < 1.16.3
    Fixed in
    1.16.3· Vendor fix available
    Issue
    kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

    Recommended action: Upgrade to 1.16.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.5PackagistPublished

    kimai2 is vulnerable to Improper Access Control

    CVE-2021-3992 · GHSA-9w8f-7wgr-2h7g

    Affected
    • Packagist kevinpapst/kimai2 < 1.16.3
    Fixed in
    1.16.3· Vendor fix available
    Issue
    kimai2 is vulnerable to Improper Access Control

    Recommended action: Upgrade to 1.16.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 8.0PackagistPublished

    kimai2 is vulnerable to Cross-site Scripting

    CVE-2021-3985 · GHSA-x68c-4gmm-5g43

    Affected
    • Packagist kevinpapst/kimai2 < 1.16.3
    Fixed in
    1.16.3· Vendor fix available
    Issue
    kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

    Recommended action: Upgrade to 1.16.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 4.3PackagistPublished

    Cross-site Scripting in kimai2

    CVE-2021-3976 · GHSA-427q-jp8v-ww95

    Affected
    • Packagist kevinpapst/kimai2 < 1.16.2
    Fixed in
    1.16.2· Vendor fix available
    Issue
    CSRF related to duplicate action. (the duplication occurs first before redirecting to edit form). This vulnerability is capable of tricking admin users to duplicate teams.

    Recommended action: Upgrade to 1.16.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Medium, CVSS 4.3PackagistPublished

    Cross-site Scripting in kimai2

    CVE-2021-3963 · GHSA-gf2c-93hm-r9j5

    Affected
    • Packagist kevinpapst/kimai2 < 1.16
    Fixed in
    1.16· Vendor fix available
    Issue
    kimai2 is vulnerable to Cross-Site Request Forgery (CSRF) in deleting invoice templates. This vulnerability is capable of tricking admin user to delete invoice templates.

    Recommended action: Upgrade to 1.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. Medium, CVSS 4.6PackagistPublished

    Cross-site Scripting in kimai2

    CVE-2021-3957 · GHSA-2xwq-h7r9-6w27

    Affected
    • Packagist kevinpapst/kimai2 < 1.16
    Fixed in
    1.16· Vendor fix available
    Issue
    Cross site request forgery vulnerability is present in delete functionality of doctor feature. This vulnerability is capable of deleting system logs

    Recommended action: Upgrade to 1.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →