Medium, CVSS 6.9PackagistPublished
Joomla Framework Database Package Vulnerable to SQL Injection
CVE-2025-25226 · GHSA-44v2-prcf-pc3m
- Affected
- Packagist joomla/database >= 3.0.0, < 3.4.0; >= 1.0.0, < 2.2.0
- Fixed in
- 2.2.03.4.0· Vendor fix available
- Issue
- Improper handling of identifiers lead to a SQL injection vulnerability in the quoteNameStr method of the database package. Please note: the affected method is a protected method. It has no usages in the original packages in neither the 2.x nor 3.x branch and therefore the vulnerability in question can not be exploited when using the original database class. However, classes extending the affected class might be affected, if the vulnerable method is used.
Recommended action: Upgrade to 3.4.0 or 2.2.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.