Medium, CVSS 5.3PackagistAmendedPublished
Converse.js Exposure of Sensitive Information
CVE-2018-6591 · GHSA-mv4h-qm24-x4gh
- Affected
- Packagist jcbrand/converse.js < 3.3.3
- Fixed in
- 3.3.3· Vendor fix available
- Issue
- Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.
Recommended action: Upgrade to 3.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.