Skip to content

← Public intelligence

Packagist package

intelliants/subrion

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

10 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    Subrion Cross-Site Scripting (XSS) vulnerability

    CVE-2020-22330 · GHSA-jj94-j4r3-5gr4

    Affected
    • Packagist intelliants/subrion >= 4.2.1, <= 4.2.1
    Fixed in
    4.2.2· Vendor fix available
    Issue
    Cross-Site Scripting (XSS) vulnerability in Subrion 4.2.1 via the title when adding a page.

    Recommended action: Upgrade to 4.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8PackagistPublished

    Subrion CMS CSRF Vulnerability

    CVE-2018-21037 · GHSA-g8j7-w673-4mjp

    Affected
    • Packagist intelliants/subrion < 4.2.1
    Fixed in
    4.2.1· Vendor fix available
    Issue
    Subrion CMS 4.1.5 (and possibly earlier versions) allow CSRF to change the administrator password via the panel/members/edit/1 URI.

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1PackagistPublished

    Subrion CMS XSS

    CVE-2018-11317 · GHSA-2cmg-vxvh-8h7h

    Affected
    • Packagist intelliants/subrion < 4.1.4
    Fixed in
    4.1.4· Vendor fix available
    Issue
    Subrion CMS before 4.1.4 has XSS.

    Recommended action: Upgrade to 4.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8PackagistPublished

    Subrion CMS CSRF Vulnerability

    CVE-2017-15063 · GHSA-rc94-7v55-wmg6

    Affected
    • Packagist intelliants/subrion >= 4.1, < 4.2.0
    Fixed in
    4.2.0· Vendor fix available
    Issue
    There are CSRF vulnerabilities in Subrion CMS 4.1.x through 4.1.5, and before 4.2.0, because of a logic error. Although there is functionality to detect CSRF, it is called too late in the ia.core.php code, allowing (for example) an attack against the query parameter to panel/database.

    Recommended action: Upgrade to 4.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1PackagistPublished

    Subrion Cross-site scripting (XSS) vulnerability

    CVE-2017-10795 · GHSA-2xv7-fwh6-x7fc

    Affected
    • Packagist intelliants/subrion <= 4.1.5
    Fixed in
    4.1.6· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Subrion CMS allows remote attackers to inject arbitrary web script or HTML via the body to blog/add/, a different vulnerability than CVE-2017-6069.

    Recommended action: Upgrade to 4.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. UnratedPackagistPublished

    Subrion CMS Cross-site scripting in search

    CVE-2014-9120 · GHSA-xjr9-2wf2-3v4w

    Affected
    • Packagist intelliants/subrion < 3.2.3
    Fixed in
    3.2.3· Vendor fix available
    Issue
    A cross-site scripting (XSS) vulnerability in Subrion CMS before 3.2.3 allows remote attackers to inject arbitrary web script or HTML via the PATHINFO to subrion/search/.

    Recommended action: Upgrade to 3.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 6.1PackagistPublished

    Subrion CMS Cross-site Scripting

    CVE-2018-14840 · GHSA-vhqr-3gr2-7px9

    Affected
    • Packagist intelliants/subrion < 4.2.2
    Fixed in
    4.2.2· Vendor fix available
    Issue
    uploads/.htaccess in Subrion CMS 4.2.1 allows XSS because it does not block .html file uploads (but does block, for example, .htm file uploads).

    Recommended action: Upgrade to 4.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Critical, CVSS 9.8PackagistPublished

    Subrion CMS PHP Object Injection

    CVE-2017-5543 · GHSA-4j79-4m6q-77vf

    Affected
    • Packagist intelliants/subrion >= 4.0.5, <= 4.0.5
    Fixed in
    4.1.0· Vendor fix available
    Issue
    includes/classes/ia.core.users.php in Subrion CMS 4.0.5 allows remote attackers to conduct PHP Object Injection attacks via crafted serialized data in a salt cookie in a login request.

    Recommended action: Upgrade to 4.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. High, CVSS 8.8PackagistPublished

    Subrion CMS vulnerable to CSRF in blog/delete

    CVE-2017-18366 · GHSA-c939-g732-48r8

    Affected
    • Packagist intelliants/subrion < 4.2.1
    Fixed in
    4.2.1· Vendor fix available
    Issue
    Subrion CMS is vulnerable to cross-site request forgery in blog/delete/. This has been patched in version 4.2.1.

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  10. High, CVSS 7.2PackagistPublished

    Subrion CMS RCE Vulnerability

    CVE-2018-19422 · GHSA-73xj-v6gc-g5p5

    Affected
    • Packagist intelliants/subrion <= 4.2.1
    Fixed in
    4.2.2· Vendor fix available
    Issue
    /panel/uploads in Subrion CMS 4.2.1 allows remote attackers to execute arbitrary PHP code via a .pht or .phar file, because the .htaccess file omits these.

    Recommended action: Upgrade to 4.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →