Medium, CVSS 6.1PackagistPublished
typo3-appointments vulnerable to Cross-site Scripting
CVE-2019-25094 · GHSA-cf5r-3pvm-w64w
- Affected
- Packagist innologi/typo3-appointments < 2.0.6
- Fixed in
- 2.0.6· Vendor fix available
- Issue
- A vulnerability, which was classified as problematic, was found in innologi appointments Extension up to 2.0.5. This affects an unknown part of the component Appointment Handler. The manipulation of the argument formfield leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.6 is able to address this issue. The name of the patch is 986d3cb34e5e086c6f04e061f600ffc5837abe7f. It is recommended to upgrade the affected component. The identifier VDB-217353 was assigned to this vulnerability.
Recommended action: Upgrade to 2.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.