UnratedPackagistPublished
ibexa/post-install affected by Breach with Varnish VCL
GHSA-4h8f-c635-25p7
- Affected
- Packagist ibexa/post-install >= 1.0.0, < 1.0.16; >= 4.6.0, < 4.6.14
- Fixed in
- 1.0.164.6.14· Vendor fix available
- Issue
- Impact This is not a vulnerability in the code per se, but included platform.sh Varnish VCL templates and Apache/Nginx vhost templates enable compression of API and JSON messages. This is a potential case of the BREACH vulnerability, which affects HTTP compression, where secrets can be extracted through carefully crafted requests. The fix disables compression in these templates. Please make sure to make the same change in your configuration files, see the release notes for specific instructions. Patches - See "Patched versions". - v1.0: https://github.com/ibexa/post-install/commit/d91cc02623dd3263a99a94ace133c95e48909e5d - v4.6: https://github.com/ibexa/post-install/commit/ae7c3c2081a862c75b90828f08bd74436ceb8fe8 Workarounds Make sure HTTP compression is disabled for REST API requests and other communication that might contain secrets. References - Advisory:…
Recommended action: Upgrade to 4.6.14 or 1.0.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.