Medium, CVSS 6.1PackagistPublished
Harvest Chosen vulnerable to Cross-site Scripting
CVE-2018-25050 · GHSA-x5q4-m45m-fm94
- Affected
- Packagist harvesthq/chosen < 1.8.7
- Fixed in
- 1.8.7· Vendor fix available
- Issue
- A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument grouplabel leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 can address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.
Recommended action: Upgrade to 1.8.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.