Skip to content

← Public intelligence

Packagist package

google/protobuf

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PackagistPublished

    Protobuf: Denial of Service issue through malicious messages containing negative varints or deep recursion

    CVE-2026-6409 · GHSA-p2gh-cfq4-4wjc

    Affected
    • Packagist google/protobuf < 4.33.6
    Fixed in
    4.33.6· Vendor fix available
    Issue
    Impact A Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input. Maliciously structured messages—specifically those containing negative varints or deep recursion—can be used to crash the application, impacting service availability. Patches Patches have been released to 5.34.0-RC1 and 4.33.6.

    Recommended action: Upgrade to 4.33.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.7PackagistAmendedPublished

    protobuf susceptible to buffer overflow

    CVE-2015-5237 · GHSA-jwvw-v7c5-m82h

    Affected
    • Packagist google/protobuf < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    protobuf allows remote authenticated attackers to cause a heap-based buffer overflow.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →