Critical, CVSS 9.8PackagistPublished
Potential Remote Code Execution in TYPO3 with mediace extension
CVE-2020-15086 · GHSA-4h44-w6fm-548g
- Affected
- Packagist friendsoftypo3/mediace >= 7.6.2, < 7.6.5
- Fixed in
- 7.6.5· Vendor fix available
- Issue
- Meta CVSS: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (9.1) CWE-325, CWE-20, CWE-200, CWE-502 Problem It has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains as described below. TYPO3-CORE-SA-2020-007, CVE-2020-15099: Potential Privilege Escalation + the database server used for a TYPO3 installation must be accessible for an attacker (either via internet or shared hosting network) + CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (7.5, high) TYPO3-CORE-SA-2016-013, CVE-2016-5091: Insecure Deserialization & Remote Code Execution + an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation + CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (9.1, critical) The overall severity of this vulnerability is critical…
Recommended action: Upgrade to 7.6.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.