Skip to content

← Public intelligence

Packagist package

dweeves/magmi

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    Magmi XSS Vulnerability

    CVE-2017-7391 · GHSA-r8vh-cm9f-rc29

    Affected
    • Packagist dweeves/magmi <= 0.7.22
    Fixed in
    0.7.24· Vendor fix available
    Issue
    A Cross-Site Scripting (XSS) was discovered in Magmi 0.7.22. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the magmi-git-master/magmi/web/ajaxgettime.php URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

    Recommended action: Upgrade to 0.7.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedPackagistPublished

    MAGMI cross-site scripting (XSS)

    CVE-2015-2068 · GHSA-27v2-398x-f74x

    Affected
    • Packagist dweeves/magmi < 0.7.22
    Fixed in
    0.7.22· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass Importer) plugin for Magento Server allow remote attackers to inject arbitrary web script or HTML via the (1) profile parameter to web/magmi.php or (2) QUERYSTRING to web/magmiimportrun.php.

    Recommended action: Upgrade to 0.7.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8PackagistPublished

    Authentication bypass in MAGMI

    CVE-2020-5777 · GHSA-g475-pch5-6wvv

    Affected
    • Packagist dweeves/magmi < 0.7.24
    Fixed in
    0.7.24· Vendor fix available
    Issue
    MAGMI versions prior to 0.7.24 are vulnerable to a remote authentication bypass due to allowing default credentials in the event there is a database connection failure. A remote attacker can trigger this connection failure if the Mysql setting maxconnections (default 151) is lower than Apache (or another web server) setting MaxRequestWorkers (formerly MaxClients) (default 256). This can be done by sending at least 151 simultaneous requests to the Magento website to trigger a "Too many connections" error, then use default magmi:magmi basic authentication to remotely bypass authentication.

    Recommended action: Upgrade to 0.7.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →