High, CVSS 7.2PackagistPublished
Drupal Two-factor Authentication (TFA) Vulnerable to Forceful Browsing
CVE-2025-31694 · GHSA-hf6c-fgp3-jfch
- Affected
- Packagist drupal/tfa < 1.10.0
- Fixed in
- 1.10.0· Vendor fix available
- Issue
- Incorrect Authorization vulnerability in Drupal Two-factor Authentication (TFA) allows Forceful Browsing. This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.10.0.
Recommended action: Upgrade to 1.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.