Low, CVSS 1.3PackagistPublished
Drupal SpamSpan Cross-Site Scripting (XSS) vulnerability
CVE-2025-31687 · GHSA-8r2q-865v-wm8j
- Affected
- Packagist drupal/spamspan < 3.2.1
- Fixed in
- 3.2.1· Vendor fix available
- Issue
- Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS). This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.
Recommended action: Upgrade to 3.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.