Medium, CVSS 5.3PackagistPublished
Drupal Reverse Proxy Header allows Manipulating User-Controlled Variables
CVE-2025-10929 · GHSA-fg8x-q69g-4qp3
- Affected
- Packagist drupal/reverse_proxy_header < 1.1.2
- Fixed in
- 1.1.2· Vendor fix available
- Issue
- Improper Validation of Consistency within Input vulnerability in Drupal Reverse Proxy Header allows Manipulating User-Controlled Variables. This issue affects Reverse Proxy Header: from 0.0.0 before 1.1.2.
Recommended action: Upgrade to 1.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.