Skip to content

← Public intelligence

Packagist package

drupal/obfuscate

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1PackagistPublished

    Drupal Obfuscate Vulnerable to Stored Cross-Site Scripting (XSS)

    CVE-2025-3130 · GHSA-hphm-3x7f-g875

    Affected
    • Packagist drupal/obfuscate < 2.0.1
    Fixed in
    2.0.1· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored XSS. This issue affects Obfuscate: from 0.0.0 before 2.0.1.

    Recommended action: Upgrade to 2.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →