Low, CVSS 2.4PackagistPublished
Drupal OAuth2 Client Cross-Site Request Forgery (CSRF)
CVE-2025-31684 · GHSA-6chf-hhqf-749c
- Affected
- Packagist drupal/oauth2_client < 4.1.3
- Fixed in
- 4.1.3· Vendor fix available
- Issue
- Cross-Site Request Forgery (CSRF) vulnerability in Drupal OAuth2 Client allows Cross Site Request Forgery. This issue affects OAuth2 Client: from 0.0.0 before 4.1.3.
Recommended action: Upgrade to 4.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.