Skip to content

← Public intelligence

Packagist package

drupal/ignition

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PackagistPublished

    Drupal Ignition Cross-Site Scripting (XSS) vulnerability

    CVE-2025-31679 · GHSA-rhxm-r44m-4325

    Affected
    • Packagist drupal/ignition < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Ignition Error Pages allows Cross-Site Scripting (XSS). This issue affects Ignition Error Pages: from 0.0.0 before 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →