Skip to content

← Public intelligence

Packagist package

drupal/google_tag

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8PackagistPublished

    Drupal Google Tag Cross-Site Scripting (XSS) vulnerability

    CVE-2025-31682 · GHSA-36vv-q5jv-94cj

    Affected
    • Packagist drupal/google_tag < 1.8.0; >= 2.0.0, < 2.0.8
    Fixed in
    1.8.02.0.8· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS). This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

    Recommended action: Upgrade to 2.0.8 or 1.8.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    Drupal Google Tag Cross-Site Request Forgery (CSRF)

    CVE-2025-31683 · GHSA-qchr-8m24-7v66

    Affected
    • Packagist drupal/google_tag < 1.8.0; >= 2.0.0, < 2.0.8
    Fixed in
    1.8.02.0.8· Vendor fix available
    Issue
    Cross-Site Request Forgery (CSRF) vulnerability in Drupal Google Tag allows Cross Site Request Forgery. This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

    Recommended action: Upgrade to 2.0.8 or 1.8.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →