Low, CVSS 1.3PackagistPublished
Drupal Formatter Suite Vulnerable to Cross-Site Scripting (XSS) via Link Element Attributes
CVE-2025-31697 · GHSA-5r66-vgc7-2mm3
- Affected
- Packagist drupal/formatter_suite < 2.1.0
- Fixed in
- 2.1.0· Vendor fix available
- Issue
- Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Formatter Suite allows Cross-Site Scripting (XSS).This issue affects Formatter Suite: from 0.0.0 before 2.1.0.
Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.