Skip to content

← Public intelligence

Packagist package

drupal/civictheme

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    Drupal CivicTheme Design System allows Cross-Site Scripting (XSS)

    CVE-2025-12083 · GHSA-h72q-cq3w-h3wc

    Affected
    • Packagist drupal/civictheme < 1.12.0
    Fixed in
    1.12.0· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CivicTheme Design System allows Cross-Site Scripting (XSS). This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.

    Recommended action: Upgrade to 1.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5PackagistPublished

    Drupal CivicTheme Design System allows Forceful Browsing

    CVE-2025-12082 · GHSA-qxr9-f877-9842

    Affected
    • Packagist drupal/civictheme < 1.12.0
    Fixed in
    1.12.0· Vendor fix available
    Issue
    Incorrect Authorization vulnerability in Drupal CivicTheme Design System allows Forceful Browsing. This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.

    Recommended action: Upgrade to 1.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →