Medium, CVSS 5.4PackagistPublished
Silverstripe cross-site scripting (XSS) attack in elemental "Content blocks in use" report
CVE-2025-25197 · GHSA-x8xm-c7p8-2pj2
- Affected
- Packagist dnadesign/silverstripe-elemental >= 2.1.2, < 5.3.12
- Fixed in
- 5.3.12· Vendor fix available
- Issue
- An elemental block can include an XSS payload, which can be executed when viewing the "Content blocks in use" report. The vulnerability is specific to that report and is a result of failure to cast input prior to including it in the grid field. References - https://www.silverstripe.org/download/security-releases/CVE-2025-25197
Recommended action: Upgrade to 5.3.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.