Skip to content

← Public intelligence

Packagist package

codeigniter/framework

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0PackagistPublished

    codeigniter/framework SQL injection in ODBC database driver

    GHSA-27qr-636m-wxg2

    Affected
    • Packagist codeigniter/framework < 3.1.0
    Fixed in
    3.1.0· Vendor fix available
    Issue
    CodeIgniter 3.1.0 addressed a critical security issue within the ODBC database driver. This update includes crucial fixes to mitigate a SQL injection vulnerability, preventing potential exploitation by attackers. It is noteworthy that these fixes render the query builder and escape() functions incompatible with the ODBC driver. However, the update introduces actual query binding as a more secure alternative.

    Recommended action: Upgrade to 3.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.7PackagistPublished

    Inadequate XSS Prevention in CodeIgniter/Framework Security Library

    GHSA-q9j3-4ghj-6h57

    Affected
    • Packagist codeigniter/framework < 3.0.3
    Fixed in
    3.0.3· Vendor fix available
    Issue
    The xssclean() method in the Security Library of CodeIgniter/Framework, specifically in versions before 3.0.3, exhibited a vulnerability that allowed certain Cross-Site Scripting (XSS) vectors to bypass its intended protection mechanisms. The xssclean() method is designed to sanitize input data by removing potentially malicious content, thus preventing XSS attacks. However, in versions prior to 3.0.3, it was discovered that the method did not adequately mitigate specific XSS vectors, leaving a potential security gap.

    Recommended action: Upgrade to 3.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8PackagistPublished

    CodeIgniter and Kohana vulnerable to PHP Object Injection

    CVE-2014-8684 · GHSA-w9ph-q4h9-rwq6

    Affected
    • Packagist codeigniter/framework < 3.0.0
    Fixed in
    3.0.0· Vendor fix available
    Issue
    CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.

    Recommended action: Upgrade to 3.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8PackagistPublished

    CodeIgniter Session Fixation Vulnerability

    CVE-2018-12071 · GHSA-g434-3q2j-hj4r

    Affected
    • Packagist codeigniter/framework < 3.1.10
    Fixed in
    3.1.10· Vendor fix available
    Issue
    A Session Fixation issue exists in CodeIgniter before 3.1.10 because session.usestrictmode in the Session Library was mishandled.

    Recommended action: Upgrade to 3.1.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →