Skip to content

← Public intelligence

Packagist package

apache-solr-for-typo3/solr

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3PackagistPublished

    Apache Solr for TYPO3 (solr) extension is vulnerable to Cross-site scripting (XSS)

    CVE-2013-6289 · GHSA-xc7q-q62f-wcvr

    Affected
    • Packagist apache-solr-for-typo3/solr < 2.8.3
    Fixed in
    2.8.3· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    Recommended action: Upgrade to 2.8.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Apache Solr for TYPO3 (solr) extension is vulnerable to Insecure Unserialize

    CVE-2013-6288 · GHSA-7m7g-jq4m-98w5

    Affected
    • Packagist apache-solr-for-typo3/solr < 2.8.3
    Fixed in
    2.8.3· Vendor fix available
    Issue
    Unspecified vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 has unknown impact and remote attack vectors, related to "Insecure Unserialize."

    Recommended action: Upgrade to 2.8.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedPackagistPublished

    Apache Solr Search for TYPO3 vulnerable to Cross-site Scripting

    CVE-2009-3821 · GHSA-2q2r-xgj5-h3hm

    Affected
    • Packagist apache-solr-for-typo3/solr <= 1.0.0
    Fixed in
    1.0.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the Apache Solr Search (solr) extension 1.0.0 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →