Medium, CVSS 5.4NuGetPublished
Umbraco Commerce vulnerable to Stored Cross-site Scripting on Print Functionality
CVE-2024-35240 · GHSA-rpj9-xjwm-wr6w
- Affected
- NuGet umbraco.commerce >= 12.0.0, < 12.1.4; < 10.0.5
- Fixed in
- 10.0.512.1.4· Vendor fix available
- Issue
- Impact Stored Cross-site scripting (XSS) enable attackers to inject malicious code into Print Functionality Patches 12.1.4, 10.0.5 References https://docs.umbraco.com/umbraco-commerce/release-notes#id-13.0.0-december-13th-2023
Recommended action: Upgrade to 12.1.4 or 10.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.