High, CVSS 7.5NuGetPublished
Improper Certificate Validation
CVE-2017-11770 · GHSA-7mfr-774f-w5r9
- Affected
- NuGet system.security.cryptography.x509certificates >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2· Vendor fix available
- Issue
- .NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly parsing certificate data. A denial of service vulnerability exists when .NET Core improperly handles parsing certificate data, aka ".NET CORE Denial Of Service Vulnerability".
Recommended action: Upgrade to 4.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.