Skip to content

← Public intelligence

NuGet package

system.private.uri

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5NuGetPublished

    Denial of service in ASP.NET Core

    CVE-2019-0981 · GHSA-5f2m-466j-3848

    Affected
    • NuGet system.private.uri >= 4.3.0, < 4.3.2
    Fixed in
    4.3.2· Vendor fix available
    Issue
    A denial of service vulnerability exists when .NET Framework or .NET Core improperly handle web requests, aka '.Net Framework and .Net Core Denial of Service Vulnerability'. This CVE ID is unique from CVE-2019-0820, CVE-2019-0980.

    Recommended action: Upgrade to 4.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5NuGetPublished

    Denial of service in ASP.NET Core

    CVE-2019-0980 · GHSA-xhfc-gr8f-ffwc

    Affected
    • NuGet system.private.uri >= 4.3.0, < 4.3.2
    Fixed in
    4.3.2· Vendor fix available
    Issue
    A denial of service vulnerability exists when .NET Framework or .NET Core improperly handle web requests, aka '.Net Framework and .Net Core Denial of Service Vulnerability'. This CVE ID is unique from CVE-2019-0820, CVE-2019-0981.

    Recommended action: Upgrade to 4.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.9NuGetPublished

    Improper Input Validation in .Net Framework API's

    CVE-2019-0657 · GHSA-x5qj-9vmx-7g6g

    Affected
    • NuGet system.private.uri >= 4.3.0, < 4.3.2
    Fixed in
    4.3.2· Vendor fix available
    Issue
    A vulnerability exists in certain .Net Framework API's and Visual Studio in the way they parse URL's, aka '.NET Framework and Visual Studio Spoofing Vulnerability'.

    Recommended action: Upgrade to 4.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →