Medium, CVSS 5.3NuGetPublished
Smidge is vulnerable to Path Traversal
CVE-2025-11842 · GHSA-9rvm-p3qm-f4vv
- Affected
- NuGet smidge < 4.6.0
- Fixed in
- 4.6.0· Vendor fix available
- Issue
- A security vulnerability has been detected in Shazwazza Smidge up to 4.5.1. The impacted element is an unknown function of the component Bundle Handler. The manipulation of the argument Version leads to path traversal. Remote exploitation of the attack is possible. Upgrading to version 4.6.0 is sufficient to resolve this issue. It is recommended to upgrade the affected component.
Recommended action: Upgrade to 4.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.