Skip to content

← Public intelligence

NuGet package

recurly-api-client

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedNuGetPublished

    Critical severity vulnerability that affects recurly-api-client

    CVE-2017-0907 · GHSA-xpwp-rq3x-x6v7

    Affected
    • NuGet recurly-api-client < 1.0.1; >= 1.1.0, < 1.1.10; >= 1.2.0, < 1.2.8; >= 1.3.0, < 1.3.2; >= 1.4.0, < 1.4.14; >= 1.5.0, < 1.5.3; >= 1.6.0, < 1.6.2; >= 1.7.0, <= 1.7.0; >= 1.8.0, <= 1.8.0
    Fixed in
    1.2.81.7.11.8.11.1.101.5.31.4.141.0.11.6.21.3.2· Vendor fix available
    Issue
    The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.

    Recommended action: Upgrade to 1.8.1, 1.7.1, 1.6.2 or 6 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →