High, CVSS 7.5NuGetPublished
.NET Denial of Service Vulnerability
CVE-2022-29117 · GHSA-3rq8-h3gj-r5c6
- Affected
- NuGet microsoft.owin.security.cookies < 4.2.2
- Fixed in
- 4.2.2· Vendor fix available
- Issue
- Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0 and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET 5.0 and .NET core 3.1 where a malicious client can manipulate cookies and cause a Denial of Service. Affected software Any .NET 6.0 application running on .NET 6.0.4 or earlier. Any .NET 5.0 application running .NET 5.0.16 or earlier. Any .NET Core 3.1 application running on .NET Core 3.1.24 or earlier. Affected packages .NET Core 3.1 | Package name | Affected versions | Patched versions | |---------------------------------------------------|-------------------|------------------| | Microsoft.Owin.Security.Cookies | <4.2.2 | 4.2.2 | | Microsoft.Owin.Security | <4.2.2 | 4.2.2 | | Microsoft.AspNetCore.App.Runtime.win-x64 | =3.0.0,3.1.24 | 3.1.25 | | Microsoft.AspNetCore.App.Runtime.linux-x64 |…
Recommended action: Upgrade to 4.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.