High, CVSS 7.5NuGetPublished
Improper Certificate Validation in Microsoft .NET Framework components
CVE-2018-0786 · GHSA-jc8g-xhw5-6x46
- Affected
- NuGet microsoft.netcore.universalwindowsplatform >= 5.2.0, < 5.2.4; >= 5.3.0, < 5.3.5; >= 5.4.0, < 5.4.2; >= 6.0.0, < 6.0.6
- Fixed in
- 5.4.25.2.46.0.65.3.5· Vendor fix available
- Issue
- Microsoft .NET Framework 2.0 SP2, 3.0 SP2, 3.5, 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, .NET Core 1.0 and 2.0, and PowerShell Core 6.0.0 allow a security feature bypass vulnerability due to the way certificates are validated, aka ".NET Security Feature Bypass Vulnerability."
Recommended action: Upgrade to 6.0.6, 5.4.2, 5.3.5 or 5.2.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.