High, CVSS 7.5NuGetPublished
.NET Core Denial of Service Vulnerability
CVE-2018-0875 · GHSA-xcvr-qv8h-m7xw
- Affected
- NuGet microsoft.netcore.jit >= 2.0.0, < 2.0.6; >= 1.1.0, < 1.1.7; < 1.0.12
- Fixed in
- 2.0.61.0.121.1.7· Vendor fix available
- Issue
- .NET Core 1.0, .NET Core 1.1, NET Core 2.0 and PowerShell Core 6.0.0 allow a denial of Service vulnerability due to how specially crafted requests are handled, aka ".NET Core Denial of Service Vulnerability".
Recommended action: Upgrade to 2.0.6, 1.1.7 or 1.0.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.