High, CVSS 8.8NuGetPublished
Vulnerability in Azure Active Directory Authentication Library
CVE-2019-1258 · GHSA-xc6x-cq47-9chw
- Affected
- NuGet microsoft.identitymodel.clients.activedirectory >= 5.0.0, <= 5.1.1
- Fixed in
- 5.2.0· Vendor fix available
- Issue
- An elevation of privilege vulnerability exists in Azure Active Directory Authentication Library On-Behalf-Of flow, in the way the library caches tokens, aka 'Azure Active Directory Authentication Library Elevation of Privilege Vulnerability'.
Recommended action: Upgrade to 5.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.