High, CVSS 7.5NuGetPublished
Denial of service in ASP.NET Core
CVE-2019-0564 · GHSA-6px8-22w5-w334
- Affected
- NuGet microsoft.aspnetcore.websockets >= 2.2.0, <= 2.2.0; >= 2.1.0, < 2.1.7
- Fixed in
- 2.1.72.2.1· Vendor fix available
- Issue
- A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka "ASP.NET Core Denial of Service Vulnerability." This affects ASP.NET Core 2.1. This CVE ID is unique from CVE-2019-0548.
Recommended action: Upgrade to 2.2.1 or 2.1.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.